Windows Movie Maker won't import .avi

posted in Video Codecs, viewed 85k times Page 1 of 3[1] 2 3 next › last »

The title pretty much says it all. My copy of windows movie maker won’t import an avi file I really need. I’ve tried updating, and everything, but it still doesn’t work. reply

Feedback
12-12-2006 05:26 PM
Invye

Hi guys I figured it out! I had the same problem, to fix it I did this

I downloaded Vista Codec pack

http://www.softpedia.com/get/Multimedia/Video/Codec-Packs-Video-Codecs/Advanced-Vista-Codec-Package.shtml

I uninstalled my current codec pack thing which was ffd show
or K lite codec pack or something. Then i installed vista codec pack and restarted the computer. Now I can import Avi’s!! yay reply

Feedback
04-18-2009 12:15 AM
Nathan12344

I recently had the same problem. After some research I found out that filters
can cause the problem. WMM 2.1 has under tools and options a compatiablty
tab. I had 26 filters in here checked. I unchecked the last 13 and tried to
import avi again and it worked. I then checked the last 6 and it failed. I
finally narrowed it down to 1 filter. I was Nero resize. You might try the
same. It should work. reply

Feedback
05-24-2009 02:43 PM
GaryV

How about being able to import but not being able to see it play out?
I can import it just fine, but only the audio will play, not the video.
What do I need to play around with to make it work?! reply

Feedback
07-04-2009 01:42 PM
SueM

hi,you can try this free software, with which you can converter AVI to WMV for Windows Movie Maker.
http://www.leawo.com/video-to-flv reply

Feedback
07-08-2009 04:33 AM
desertfish
7 posts

GaryV wrote:
I finally narrowed it down to 1 filter. I was Nero resize. You might try the
same. It should work.

XP SP2 WMM 2.1
This fixed me too!. It was NeVideo.ax. for me. I had removed Nero Burner software already fighting it and had been in the codec list 30 times but failed to just use process of elimination. Thank you GaryV. reply

Feedback
10-03-2009 02:29 AM
ezas314159

I had to change my xVid filter reply

Feedback
11-11-2009 08:23 PM
abc123na

GaryV’s solution works!! Just tweak it til you find whichever one it is. Lovin' it reply

Feedback
01-24-2010 06:04 AM
Riley

You need to install a set of video audio codecs. Here are the latest media codecs K-Lite Codeck Pack FULL http://depositfiles.com/ru/files/xupbyy482
But for Windows 7 is also a set of codecs http://depositfiles.com/files/0zbz3mnzl reply

Feedback
01-25-2010 02:36 AM
grandy
1 posts

I installed the K-Lite codecs and everything but i still have only 2 filters under the compatibility tab in WMM... and it still won’t play the video, only the audio when i import a file.

the two filters i have are avi decompressor and microsoft dtv/dvd audio decoder...

HELP PLEASE! reply

Feedback
02-27-2010 12:07 PM
Bubbles89

I’ve had the same problem with importing .AVI files in Windows Movie Maker. Just try to check all filters and see what happens. I have VistaCodecPack installed on my computer, and “ffdshow video decoder” (and “DivXAntiFreeze”) was by default unchecked. It worked by me. reply

Feedback
04-06-2010 05:00 AM
Cecile

I just downloaded WMM2.6 And that supports it :) reply

Feedback
06-07-2010 12:05 PM
Jenny Young

it won’t work for me. when i pull up WMM on my xp it only has five of those files. i’ve tried a few things, but its still not working. and my computer won’t let 2.6 be downloaded. it says that it has to be a vista version of windows or higher. what can i do? T___T i wanna make an epic vampire knight vid, and i don’t feel like locking up the computer for the next ten hours while all 26 episodes convert to wmv format... reply

Feedback
07-09-2010 01:35 PM
Rahr

What codec do they use? Do they play in WMP? reply

Feedback
08-06-2010 05:10 AM
low_profile
28 posts

GaryV wrote:
I
finally narrowed it down to 1 filter. I was Nero resize. You might try the
same. It should work.

Thank you so much! I’d tried everything to try and import avi videos and it hadn’t worked but this totally saved my movie! reply

Feedback
08-06-2010 05:34 AM
LiBo

He great! I couldn’t add some files to wmm(would freeze up) but also went into options and just de-clicked some filters and now only got 1 clicked, but it works great!
Let me add that I have no clue what these filters r but just un-click some and try, then repeat if it still doesn’t work! Out of the 13 rso filters, I now only have 2 r 3, but works great!

Big thanks to all contributing! reply

Feedback
10-07-2010 01:28 PM
got it

i tried to go to tool>options>compadability then uncheck the filter. but i only have 1 filter and it doesnt make a difference reply

Feedback
12-20-2010 07:37 PM
wolflover

Mine says
__________cannot be imported because the codec required to play the file is not installed on your computer. If you have already tried to download and install the codec, close and restart Windows Movie Maker, and then try to import the file again.

Nothing I do will fix it even installing more codecs i have no idea what to do and no ones solutions are working reply

Feedback
01-07-2011 08:49 PM
Steven

Nathan12344 wrote:
Hi guys I figured it out! I had the same problem, to fix it I did this

I downloaded Vista Codec pack

http://www.softpedia.com/get/Multimedia/Video/Codec-Packs-Video-Codecs/Advanced-Vista-Codec-Package.shtml

I uninstalled my current codec pack thing which was ffd show
or K lite codec pack or something. Then i installed vista codec pack and restarted the computer. Now I can import Avi’s!! yay

Thank you very much....this method works perfectly..... reply

Feedback
01-12-2011 10:00 AM
sk

windows movie maker sucks , the ideal video format for WMM is WMV , you’d better convert your avi to wmv with some video conversion tool, such as FFMPEG reply

Feedback
01-13-2011 02:53 AM
junian116
24 posts

Page 1 of 3[1] 2 3 next › last »

Reply

Topic
Your reply
Your name
or log in
Verify you're human

By submitting this form you agree to our posting rules,
privacy policy and our disclaimer.

Latest downloads