Help with virtualdub warning

posted in Video Codecs, viewed 25k times

Couldn’t locate decompressor for format H264

VirtualDub requires a video for windows(VFW) compatible codec to decompress.

anyone help? reply

Feedback
04-03-2008 10:44 AM
darrennnnnn

Use ffdshow tryouts
During install make sure to check the boxes 'VFW Interface' and 'VirtualDub' under 'Application plugins'.
If you already have other codecs, and you don’t need ffdshow to decode anything except H264 in VirtualDub, uncheck everything else except “H.264/AVC” at the two steps where it lets you choose what codecs ffdshow should decode.
When you’re done, go to your start menu (all programs on XP), ffdshow, VFW configuration. Select the decoder tab, and click on Codecs on the upper left. Click on “H.264/AVC” on the right, and in the middle column make sure it’s NOT disabled (aka libavcodec is selected). Then click apply and your H264 video should be openable in VirtualDub.

I know there’s other H264 decoders out there, but I’m not really up-to-date on which ones are VfW. reply

Feedback
04-03-2008 01:32 PM
anonymous
1,580 posts

This works, it’s a little step intensive but i have new sony camcorder with different avi flavor and vdub won’t open it, now it will. reply

Feedback
06-28-2010 07:37 PM
JBV

You’re a beast, worked perfect!!! reply

Feedback
08-06-2011 01:53 PM
Gerrit

oh thank you thank you thank you!!! reply

Feedback
10-18-2011 08:35 AM
P2nkzSB

thanks ... reply

Feedback
04-03-2012 04:34 PM
sabkyu

thankssssssssssss reply

Feedback
03-26-2013 10:55 PM
argenmu

You’re great!!
Thanks a big deal =) reply

Feedback
06-13-2013 10:59 AM
micky83

Anyway, I needed DivX as well, as reader for the file avi, instead of WindowsMedia. Otherwise virtualdub visualizes an error.

I hope it can help you,
bye

michi reply

Feedback
06-13-2013 11:07 AM
micky83

I did as anonymous said but, under the decoder tab, i can’t APPLY “H.264/AVC” because this APPLY button is not active
reply

Feedback
06-23-2013 07:38 AM
Jac100
1 posts

I’m the same as Jac100. I followed all the steps, but when it came to clicking “Apply”, the button was greyed out because there was nothing TO apply. The H.264/AVC codec was already active, but when I ran Vdub again, it showed the same error as before and couldn’t open my file.

What am I missing? reply

Feedback
08-03-2013 05:57 PM
xynnia

Man it`s totally amazing!!!!!!! Thanks a lot!!! reply

Feedback
08-20-2013 05:42 AM
ThanatoSpy

I am with xynnia here it doesn’t work :/ reply

Feedback
10-06-2013 07:34 AM
helpmeplz

followed step by step. does not work. reply

Feedback
02-18-2014 04:02 PM
dreemsnake

Reply

Topic
Your reply
Your name
or log in
Verify you're human

By submitting this form you agree to our posting rules,
privacy policy and our disclaimer.

Latest downloads