Subtitles in Media Player Classic

Page 2 of 3« first 2

02-22-2010 11:35 AM
ocinem61
1 posts

Bluray: Problem with forced subtitles

I ask for help to solve this problem.
forced subtitles are those subtitles that appear when a scene requires it and then disappear. This subtitle, other than permanent, turn on the actors speak a language other than the one selected, or when it is always a sign written in different languages.

In the case of film Angels and Demons (Italian version) in the opening scene (from 3.54 to 4.40 minutes) is spoken French language losing part of the meaning of the scenes, this is a very important fact for the understanding of a film.

This is the example of Bluray Angels and Demons seen with PowerDVD9 in Italian

http://www.allfreeportal.com/imghost/images/518494Ridimensiona%20diSenza%20titulo-2.PNG

http://www.allfreeportal.com/imghost/images/160889Ridimensiona%20diSenza%20titulo-3.PNG

Wonder if you can resolve this problem with some setting or codec would be a major step forward for this great player to play Bluray, but should be complete for the navigation of the menu, but I think this is still possible for a matter of licensing.

Thank reply

Feedback

04-09-2010 09:49 AM
zaza

someonee..please help mee.. how i gonna appear my subtitle in media player classic.. actually.. my cd was dvd.. it is korean drama.. but.. the subttile don’t want to come outt.. i don’t know what to do now... please help meee.. :((( reply

Feedback

07-07-2010 03:19 AM
asd

thx all brothersss :) reply

Feedback

08-04-2010 12:31 PM
jinxie

I finally got the subtitles to show up, using the tips left here, but the video itself is nowhere to be seen...

Someone please help me with this... reply

Feedback

10-13-2010 06:38 AM
lanerfy

thanks to alternipunker! whew reply

Feedback

11-08-2010 02:21 PM
yo

tks !!!!!! reply

Feedback

11-26-2010 05:19 PM
lastone05

Is there a way to keep the subtitles on the video like whenever you open it their there and its like witht he file reply

Feedback

12-06-2010 01:02 AM
Grateful

THANK YOUUUUUUUUUU :) reply

Feedback

12-20-2010 01:13 PM
GVK

Thanks bobarnas! Now I can play subs in mkv vids. :D reply

Feedback

12-31-2010 04:08 PM
Burnquist

Thanks bujju. This is what worked for me, I changed the name of the movie to exactly what it was inststead of those long names with like dvdrip2010xvid.avi at the end of the title but when u do that you have to change the name of the subtitle file to whatever you change it to. Thanks that worked.

bujju wrote:
hey guys just change the sub tiltle name. it shud be same.

like movie file name is " G-Force.mp4 " then change the sub title file name too " G-Force.srt " it sud be in a same folder.

reply

Feedback

02-05-2011 02:58 PM
varun

alternipunker wrote:
Hey guys,

I had the same problem with media player classic. A lot of the advice I read left out one crucial point which I help put here...

In media player classic go to View -> Options -> Playback -> Output -> DirectShow Video -> VMR7(renderless) or VMR9(renderless). Then when you play the file, go to File --> Load Subtitle.

That works for me. I hope it helps someone else.

excellent ,,, awesome,,,, it worked for me too,,, long live u ,, and ur progeny....:):):) reply

Feedback

03-12-2011 02:23 PM
The Animal

THANK YOU!!!! That last bit of info (File, Load Subtitle) did the trick! reply

Feedback

03-28-2011 03:53 PM
SABER

I am playing a video in MPC and its got embedded subtitles. I’ve used the KLM Mega Codec Pack and the subtitles work just fine. The only problem is they appear in simple Arial instead of the preset version. It works in VLC where i get to see the subtitles in their original font size, shape and colour. But for MPC with KLM or without it they get resized and modified to a simple white Arial bold font. I’d rather like to see the more colourful version for MPC. I’ve tried everything that’s given above and it hasn’t worked yet. So I’d be grateful if someone could help me out. reply

Feedback

04-10-2011 08:51 AM
Shahriar

Thanks a lot reply

Feedback

05-26-2011 09:29 PM
salas

please help to solve this prob. with media player classic:how to switch subtitle on,i cant save any subtitle,when i click on subtitle after 30 seconds it says:cant find subtitle database,please answer me!tnx! reply

Feedback

06-04-2011 04:50 AM
shakti

how to set subtitle in media player classic? reply

Feedback

07-01-2011 02:31 AM
ankon

every time i try to load subs(downloaded from subscene) my km player just wont load it.a box appers and says update codecs.i dont knw wat to do,plz help me. reply

Feedback

07-21-2011 09:02 AM
eddy ryan

thank u so much!! was trying to change the sub file to srt, n then i came upon this!!! reply

Feedback

07-28-2011 01:55 AM
aishah

my video movie dont have a subtitle,what should i do? please help me reply

Feedback

10-28-2011 07:39 AM
thatlaquada

ok, goog. reply

Feedback

Page 2 of 3« first 2

Post Your Answer

Topic
Your reply
Your name
or log in
Verify you're human

By submitting this form you agree to our posting rules,
privacy policy and our disclaimer.